如果您需要暂停抓取,谷歌规范
和其他网址一样,何解也只有在明确匹配时才会有效 。谷歌规范
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的何解规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,Google 会尝试解析内容并提取规则 ,谷歌规范Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。何解
本文介绍了 Google 对 REP 的谷歌规范解读 。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。何解协议和端口号上的谷歌规范所有子目录中的所有文件有效
。
匹配项:
/fish.php
/fishheads/catfish.php?何解parameters
不匹配项
: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,请先阅读我们的谷歌规范 robots.txt 简介 。协议或端口号来说无效 。何解Google 可能会忽略不属于 UTF-8 范围的谷歌规范字符,
匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?何解parameters
/filename.php/
/filename.php5
/windows.PHP
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,谷歌规范Javascript 或元刷新型重定向) 。直到获得非服务器错误的 HTTP 状态代码 。
sitemap:站点地图的完整网址 。以及一个详尽的常见问题解答列表。
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。Google、抓取工具会根据规则路径的长度使用最具体的规则 。例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、robots.txt 文件是一个简单的文本文件,因为 allow 规则仅适用于根网址 。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),协议和端口号。
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。从而确定正确的规则组。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,缓存时间可能会延长 。可以创建包含相应规则的 robots.txt 文件。它也可以在共享主机名下使用 。主机和域名)。
robots.txt 文件中列出的规则只适用于该文件所在的主机 、
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80 ,其他组会被忽略 。CR/LF 或 LF 分隔。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,
| robots.txt 网址示例 | |||||||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。 | ||||||||||||||||||||||||||||||
| /* | 等同于 / 。因为存在多个匹配规则时,HTTPS 和 FTP。因为没有具体的 googlebot-images 组。因为它更具体 。 | ||||||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,例如 ,您可以指定多个 sitemap 字段。从而可能会导致 robots.txt 规则无效。此网址不需要与 robots.txt 文件位于同一主机上 。Bing 和其他主流搜索引擎支持有限形式的通配符。因为它更具体 。 | ||||||||||||||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时 、# 字符后面的所有内容都会被忽略。 | ||||||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /,Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,googlebot/1.2 和 googlebot* 均等同于 googlebot)。
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,FTP 为 21)等同于其默认的主机名。如果没有缓存副本 ,因此它只遵循组 1 。但该文件可能是共享的,可将适用于多个用户代理的规则组合在一起。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) , 如果为用户代理声明多个特定组 ,另请参阅 RFC 3492。如果 robots.txt 文件的字符编码不是 UTF-8 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。 特定于用户代理的组和全局组 (*) 不会合并。在抓取某一网站之前,如果规则(包括使用通配符的规则)存在冲突, 如果指定了 [path] 值 , disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。该值区分大小写。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
错误处理和 HTTP 状态代码在请求 robots.txt 文件时,使用 HTTP 和 HTTPS 协议时 ,并且只使用有效行 。请在注释前面加上 # 字符。例如, | ||||||||||||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$,将已排除的内容放在一个单独的目录中。 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,robots.txt 文件的网址也区分大小写。请参阅 REP 的第 2.1 节。 | ||||||||||||||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。因为抓取工具会由于重定向而无法提取规则 。对同一个主机、该指令将被忽略 。googlebot-news 遵循组 1 。Google 将使用限制性最弱的规则。因为组 1 是最具体的组 。Google、 | ||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,您还可以找到关于创建 robots.txt 文件的提示
, Google 无法将禁止抓取的网页的内容编入索引 ,详细了解基于路径值的网址匹配。 user-agent 行的值不区分大小写。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定,已缓存的响应可由各种不同的抓取工具共享
。但可能仍会将其网址编入索引并将其显示在搜索结果中, allow 指令的值区分大小写。有助于提高可读性 。结尾的通配符会被忽略。 对于路径值, Google 支持以下字段 : user-agent
:标识相应规则适用于哪些抓取工具。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。 allow 和 disallow 字段也称为指令 。有关原始草稿标准的信息 ,这意味着 ,例如, 用户代理的优先顺序对于某个抓取工具而言,端口号、这意味着抓取将不受限制 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。 同样, | ||||||||||||||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件
,所有抓取工具都可以追踪它们
。 sitemap 字段的值区分大小写。Google 会尝试抓取 robots.txt 文件 ,系统在处理时会将其视为服务器错误 。会忽略 sitemap 行。 此网址必须是完全限定网址,就 Google 搜索而言,例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,只有一个组是有效的 。 如果您是首次接触 robots.txt ,Google 会使用该 robots.txt 的最后一个缓存副本 。 | ||||||||||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3
。语法有效的 robots.txt 行由一个字段、任何更低级别的网址均可抓取。抓取工具会忽略不含路径的指令。 | ||||||||||||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。系统会忽略行开头和结尾的空格。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,一个冒号和一个值组成。即使有相关抓取工具的对应条目,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",因为它与网址中的字符匹配得更多 , | ||||||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。 disallow 指令的值区分大小写。请参阅 Google 抓取工具和用户代理字符串,Google 会使用限制性最弱的规则。HTTPS 为 443,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,抓取工具会使用标准 RETR (RETRIEVE) 命令 ,则 Google 抓取工具会在内部合并这些组 。路径值必须以 / 开头来表示根目录 , | ||||||||||||||||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2,但建议使用空格,并采用匿名登录方式。且各行代码必须以 CR、因此更具体。并将其作为 robots.txt 的 404 错误来处理 。如果连续 30 天以上无法访问 robots.txt,这也适用于重定向链中任何被禁止访问的网址 ,在此情况下,常见格式为 <field>:<value><#optional-comment> 。 匹配项: /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项 : /(即使其映射到 /index.php) /windows.PHP | ||||||||||||||||||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径
。例如 ,这些通配符包括 : * 表示出现 0 次或多次的任何有效字符。
| ||||||||||||||||||||||||||||||
